ELECTRON BATT fuse? - S-Chassis.com

Audio, Video and Security Stereos, Subs, In-Dash Tv's and alarms

ELECTRON BATT fuse?

Reply

 
 
 
Old 06-30-2008, 04:08 PM
  #1  
Registered User
Thread Starter
 
fadedsilvia's Avatar
 
Join Date: Jun 2008
Location: Madison, Wisconsin
Posts: 221
ELECTRON BATT fuse?

this thread is continued from "low volume, ne ideas?"

i came to the conclusion that the stock radio was bad so i removed it an put some speakers in the back an got a jvc deck
me an my friend (both of us mechanics) spent about 4 hours tryin to figure out the sweet wiring job the last douchebag did an gave up an took it to best buy haha
sooo they got it all workin the volume was great it played through all the speakers
then on the way home from best buy the sound cut out but the cd player still had power an everything so i got home an took it all out an the ground was in a stupid place an looked like it had been shorting on acount of it bein burntish sooo i put it on a more solid ground annn then this mysterious freakin ELECTRON BATT fuse blows
everytime i put a new fuse in its blows it imediately, doesnt even need the key in the ignition an i cannot find newhere what the hell this fuse is

so does neone know what its for an y it keeps blowing? could it be a grounding issue through the radio?

sry for such a long message jus wanna get ne info that could help out here
fadedsilvia is offline  
Reply With Quote
Old 06-30-2008, 05:04 PM
  #2  
Registered User
Thread Starter
 
fadedsilvia's Avatar
 
Join Date: Jun 2008
Location: Madison, Wisconsin
Posts: 221
so i took a look at the amps under the rear deck an saw that the last guy who had the car tried to do the amp bypass

wether or not he did it right? i have no idea but im thinkin he didnt an thats y i keep blowin that fuse an losin power

i went onto the amp bypass thread a couple below this one an read up on it

an it looks like the guy mixed up a couple wires an pluges the constant 12v (blue stripedy wire) to either one of the rear speaker wires or HU input wire


im akin it all back to best buy again tomorrow an makin em do it for free until they get it right but if that amp bypass is wrong i dunno if they will be able to get it right

this make ne sort of sense to neone?
fadedsilvia is offline  
Reply With Quote
Old 07-02-2008, 12:06 PM
  #3  
Registered User
Thread Starter
 
fadedsilvia's Avatar
 
Join Date: Jun 2008
Location: Madison, Wisconsin
Posts: 221
sooo i spent a couple hours at best buy workin with the dudes an we ended replacing the ground wires an power wires in the harness after the deck burned those up an then the deck itself let out its magic blue smoke

so we got a new deck, placed the wiring fixed the amp bypass got all the fuses to not blow nemore an everything works great....until jus now this morning

battery is dead hopefully tehre is just a draw sumwhere, i doubt its the radio cuz for some reason the window motor decided to start running but not go newere so im thinkin the switch for that is bad cuz it also doesnt roll up every time i push it
so i only have one thing to say, this car is an electrical nightmare!
fadedsilvia is offline  
Reply With Quote
Old 07-02-2008, 03:52 PM
  #4  
Registered User
Thread Starter
 
fadedsilvia's Avatar
 
Join Date: Jun 2008
Location: Madison, Wisconsin
Posts: 221
nope i was wrong i traced it to the egnition circiut
fadedsilvia is offline  
Reply With Quote
Old 07-08-2008, 04:09 AM
  #5  
Contributing Member
 
Initial Daniel's Avatar
 
Join Date: Oct 2004
Location: Woodbridge
Posts: 886
Wow. That sounds horrible man. I'd make sure that all your ignition wires are in tact.
Initial Daniel is offline  
Reply With Quote
Old 07-08-2008, 04:12 AM
  #6  
Contributing Member
 
Initial Daniel's Avatar
 
Join Date: Oct 2004
Location: Woodbridge
Posts: 886
Originally Posted by fadedsilvia View Post
nope i was wrong i traced it to the egnition circiut
Furthermore, If everything worked prior to taking it to Best Buy, I'd make them do it. Seriously, unless you're afraid they might screw it up even more. Even if that is the case, you can legally bind them to fix that, because it was in their hands at the time of the error, etc.

You could get your insurance company to even cover re-wiring or whatever from the dealer and have Best Buy pay for it. Up to you.

I'd make sure they fixed it though.
Initial Daniel is offline  
Reply With Quote
Old 07-08-2008, 07:18 PM
  #7  
Registered User
Thread Starter
 
fadedsilvia's Avatar
 
Join Date: Jun 2008
Location: Madison, Wisconsin
Posts: 221
yea they fixed it fo sure they had to replace a the power wire in the harness twice an put in a fuse the second time so they wouldnt have to again haha
but yea aparently the radio takes its power from the ignition circuit when the car is off to store info and the draw that was sumwhere was no longer there sooooo im not actually sure what it was but it hasnt done it since so unless it does it again im not to terribly concerned about it
but thanks for the tip ill keep that in mind if sumthin burns up that they did, even though its under a warranty so itll be free to get fixed but id prolly jus do it myself neway

other than that everything, except for the slippy clutch paint an suspension, is great on the car

im not gonna do paint until i do a kouki front end and suspension an clutch will be done very soon

Last edited by fadedsilvia; 07-08-2008 at 07:23 PM.
fadedsilvia is offline  
Reply With Quote
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
aero528
General
4
08-19-2009 11:58 PM
accel junky
For Sale - Cars For Sale
5
03-27-2005 07:34 AM
roneosf
General
14
11-26-2002 05:47 PM
Jonas
General
17
10-02-2002 02:49 PM
Jolt21
Off-Topic
1
09-28-2002 03:20 PM


Thread Tools
Search this Thread
Quick Reply: ELECTRON BATT fuse?


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.