Bov not functioning properly - S-Chassis.com

Go Back  S-Chassis.com > Technical Discussions > Turbo Motor > SR
Reload this Page >

Bov not functioning properly

Bov not functioning properly

Reply

 
 
 
Old 07-13-2011, 04:05 PM
  #1  
Registered User
Thread Starter
 
Join Date: Oct 2007
Location: Lincoln, NE
Posts: 40
Bov not functioning properly

hey guys,

Ive been having this problem with my BOV, and I've had great luck with help from this forum in the past. I have tried to fix this problem a few different ways, but to no avail,,, heres the story

I gots an s14 sr20 in a 96 240. All hardpipes, HKS BOV and wastegate, full exhaust turbo back, greddy boost controller.

Ive had this setup for quite some time, at least 4years, 60k miles. The bov has always worked flawlessly with no flutter. The craziest part is that i have the bov line coming from the vacuum on the intake mani, tee'd twice to a boost gauge and boost controller. I know this is BAD,, but ive never had a single problem with this setup. always worked great

I just drove the car on a 500mile road trip and notice it was starting to flutter. Checked the boost lines and sure enough i had a rip right by the BOV, i cut the tear out and reattached but it is STILL causing some flutter and i am not happy,, how can people say this sounds cool???

Yesterday i removed the bov lines and left the boost gauge unhooked, bought all new lines and ran the BOV on its own brand new line from the intake mani to the bov with no tee's. But this didnt help at all, same thing

Basically, the BOV is opening, but not for long enough,, I get a blow off, then flutter from the intake filter after the bov closes early,, Never done this before and I am not impressed, and i dont want to tear anything up. I am down to two options,,

1) clean the HKS SSQV,, i hear this helps sometimes
2) get a new BOV,,

I was wondering if anyone else had any suggestions as to what else i could take a look at.. any suggestions would be greatly appreciated!! Thanks guys in advance
redd100 is offline  
Reply With Quote
Old 07-14-2011, 01:53 AM
  #2  
Contributing Member
iTrader: (2)
 
Biggamehit's Avatar
 
Join Date: Aug 2004
Location: Misawa, Japan
Posts: 5,091
BOVs go bad yours has died... sorry.

ps

atmoshperic venting is wasteful
Biggamehit is offline  
Reply With Quote
Old 07-14-2011, 03:11 PM
  #3  
Registered User
Thread Starter
 
Join Date: Oct 2007
Location: Lincoln, NE
Posts: 40
Originally Posted by Biggamehit View Post
BOVs go bad yours has died... sorry.

ps

atmoshperic venting is wasteful
Hey thanks for the quick reply game, I thought this was the case too,, Surprisingly someone is selling brand new authentic hks ssqv on ebay for 80 right now, what a steal.

I realize venting is wasteful, but it is also sexy!!
redd100 is offline  
Reply With Quote
Old 07-15-2011, 05:39 AM
  #4  
Contributing Member
iTrader: (2)
 
Biggamehit's Avatar
 
Join Date: Aug 2004
Location: Misawa, Japan
Posts: 5,091
you can still hear it if you re route it brother.

I had a leaky blitz before man.. i was in denial about it lol... put on a dsm bov and no issues.
Biggamehit is offline  
Reply With Quote
Reply
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
ProjectRelicS13
S-Chassis Newbie / FAQs Forum
21
04-21-2008 06:20 PM
Talde
How To Requests / Questions / Tips
5
04-15-2008 05:48 AM
bucket240
Suspension, Chassis, and Brakes
31
05-09-2007 12:15 PM
EDog
General
0
08-11-2005 06:48 AM
WhiteWolf
For Sale - Wanting To Buy (WTB) Or Trade (WTT)
0
07-07-2005 08:38 AM


Thread Tools
Search this Thread