Suspension, Chassis, and Brakes Make your 240sx/Silvia's handling better and stopping faster.
Sponsored by:
Sponsored by:

Noisy Spring????

Old 09-15-2007, 12:38 AM
  #1  
Contributing Member
Thread Starter
 
positron's Avatar
 
Join Date: Sep 2002
Location: Starkville, MS.
Posts: 1,192
Noisy Spring????

Recently I've been hearing a creaking sound from the left drivers side of my car. I can hear it sometimes when I get in and out of the car and sometimes when I get down and pull on the rim. I've jacked the car up and checked for loose connections on all my suspension and struts and found nothing. The only thing I can think of is a noisy spring? Can anyone chime in on this. I hate not knowing where this is coming from. Or should I just lose 20lbs. off my [email protected]$$!!!!
positron is offline  
Old 09-15-2007, 09:54 AM
  #2  
Contributing Member
iTrader: (1)
 
Join Date: Dec 2005
Location: kennewick wa.
Posts: 2,323
it sounds like it's just the coils. it's quite common, click on the link about 3/4 of the way down you'll see the solution.
http://www.pdm-racing.com/products/suspension.html
jramosthe1st! is offline  
Old 09-15-2007, 01:14 PM
  #3  
Contributing Member
Thread Starter
 
positron's Avatar
 
Join Date: Sep 2002
Location: Starkville, MS.
Posts: 1,192
You know, I've been reading about those things on that site for years and never put two and two together. I think you just solved my problem...thanks!!!!
positron is offline  
Old 09-15-2007, 01:19 PM
  #4  
Contributing Member
iTrader: (1)
 
Join Date: Dec 2005
Location: kennewick wa.
Posts: 2,323
always happy to help.
jramosthe1st! is offline  
Old 09-15-2007, 04:00 PM
  #5  
Registered User
 
neville610135's Avatar
 
Join Date: Apr 2006
Location: Central Coast, CA
Posts: 237
on a similar issue, mine are noisy, but they sound like they are bottoming out. is that the same noise? its not a creak more like a bump
neville610135 is offline  
Old 09-15-2007, 04:17 PM
  #6  
Contributing Member
iTrader: (1)
 
Join Date: Dec 2005
Location: kennewick wa.
Posts: 2,323
probably not, your problem is more likely a bad shock or strut.
jramosthe1st! is offline  
Old 10-04-2007, 04:01 PM
  #7  
Contributing Member
Thread Starter
 
positron's Avatar
 
Join Date: Sep 2002
Location: Starkville, MS.
Posts: 1,192
I pulled the strut assembly and found that the rubber insolater had come loose from the top mount so I put it back on as snug as possible and the noise is practically gone. I can still hear it sometimes but I think it's because that rubber isolater is in such bad condition. I think I'll get some new ones or some camber plates.
Name:  IMG_1470.jpg
Views: 0
Size:  121.8 KB
Name:  IMG_1472.jpg
Views: 0
Size:  89.9 KB
Name:  IMG_1473.jpg
Views: 0
Size:  89.3 KB
positron is offline  
Old 10-04-2007, 04:31 PM
  #8  
Contributing Member
iTrader: (1)
 
Join Date: Dec 2005
Location: kennewick wa.
Posts: 2,323
i thought you were talking about the front.
jramosthe1st! is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
ryan15
Suspension, Chassis, and Brakes
1
03-07-2004 11:18 PM
altima/240sx
Suspension, Chassis, and Brakes
4
12-31-2002 03:49 PM
spitz7985
Suspension, Chassis, and Brakes
1
12-14-2002 10:11 AM
spitz7985
Suspension, Chassis, and Brakes
3
09-05-2002 10:19 PM
RNN14
Private For Sale / Wanted
8
04-30-2002 10:06 PM


Thread Tools
Search this Thread
Quick Reply: Noisy Spring????


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.