SR20DET possibly a major issue - S-Chassis.com


Reply
 
 
 
Thread Tools Search this Thread
Old 04-02-2014, 02:14 AM   #1
Registered User
Thread Starter
 
Join Date: Mar 2014
Location: Delaware
Posts: 1
SR20DET possibly a major issue

To start of I have a 91 240sx with and sr20det swap. Im running a top mount turbonetics t3 turbo, 680cc precision injectors, precision turbo wastegate, and an apexi power fc. The car has not been tuned yet, since Ive only had the car roughly 2 months. I went to take it through inspection today and as i was pulling out of my drive way the car just started dumping white smoke. Whenever it is at idle it smokes slightly, but the moment I put any type of load on the motor it just pours smoke. This is the first turbo'd car I have owned and I am not sure what is causing this issue. Any input would be greatly appreciated.
BoostedSR20 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
electrical issue,stater issue, alt issue....dont know HELP onelove240 General 4 03-22-2008 08:50 PM
Wiper and windshield washer issue + Rpm issue redpotatoes NA Motor 4 12-22-2005 10:00 AM
Possibly FS: SIL-40 (SR20DET) Exessive26 Private For Sale / Wanted 3 03-03-2004 10:03 PM
WTB: s13 Redtop Major parts adavib Private For Sale / Wanted 0 11-10-2003 11:27 PM
major problem paniro4 NA Motor 1 11-21-2002 09:44 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -7. The time now is 11:43 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.