Go Back  S-Chassis.com > Technical Discussions > NA Motor
Reload this Page >

1992 240SX - High idle after shifting into neutral

NA Motor Discussions regarding N/A KA24E, KA24DE, and SR20DE

1992 240SX - High idle after shifting into neutral

Old 05-23-2008, 09:33 PM
  #1  
Registered User
Thread Starter
 
Join Date: May 2008
Location: a
Posts: 2
1992 240SX - High idle after shifting into neutral

The engine is the stock KA24DE. Sometimes when I drive, shift into neutral, and come to a stop the idle is high. The engine will idle around 1,300 to 1,800 RPM for a varying amount of time and then it will drop back down to 800 RPM.

I'm pretty sure it has something to do with the weird noise that is seeming to come from the head.

Here is a link to a sound clip of the engine noise:
http://www.angelfire.com/daywickell/Engine.mp3
(copy and paste the link)

I started the car and let it warm up. When the engine starts to idle at 800 RPM a weird metallic rolling sound will start happening. If I rev the engine the sound will go away but once the engine is back to idle the sound will come back.

Any ideas on why I have high idle after driving and shifting into neutral or what that weird idle sound is?

Last edited by DaywickelL; 05-23-2008 at 09:47 PM.
DaywickelL is offline  
Old 05-28-2008, 11:16 PM
  #2  
Contributing Member
 
dkdeleon's Avatar
 
Join Date: Oct 2002
Location: arlington texas
Posts: 593
the sound is most likely your top chain guide. you can remove it and the sound will go away. also for the idle problem check your throttle cable to see if it is sticking or binding.

Last edited by dkdeleon; 05-28-2008 at 11:20 PM.
dkdeleon is offline  
Old 05-29-2008, 05:53 AM
  #3  
Contributing Member
 
crazydrifter's Avatar
 
Join Date: May 2006
Location: VA
Posts: 510
my old SR idled high in neutral, but that was only when it was cold. after it would warm up it would stop, but i never knew what it was.
crazydrifter is offline  
Old 05-30-2008, 05:10 PM
  #4  
Registered User
iTrader: (2)
 
BigVinnie's Avatar
 
Join Date: Nov 2004
Location: Walnut Creek
Posts: 2,502
Turn down your IACV a tad. You may also be using an Auto ecu which idleshigher than the 5 speed manual tranny ecu's.
Also replace your timing chain guides.
BigVinnie is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
toycar
General
2
07-14-2005 02:31 AM
johna_99_99
General
0
04-28-2005 06:34 PM
jmack240
NA Motor
7
04-29-2004 08:00 AM
-=93240sxguy=-
General
2
12-30-2003 06:13 PM


Thread Tools
Search this Thread
Quick Reply: 1992 240SX - High idle after shifting into neutral


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.